安装gitbook脱坑笔记-实测有效

安装gitbook脱坑笔记-实测有效

Scroll Down

安装gitbook脱坑笔记-实测有效

gitbook -V 安装过程报错

报错1

xcode-select: error: tool 'xcodebuild' requires Xcode, but active developer directory '/Library/Developer/CommandLineTools' is a command line tools instance

解决方案:

  1. sudo xcode-select --switch /Applications/Xcode.app/Contents/Developer/ 切换到当前Xcode路径下
  2. xcodebuild -showsdks
  3. xcrun --sdk iphoneos --show-sdk-path

报错2

由于不支持高版本的nodeJS,所以我们需要Nodejs进行降级处理

解决方案:

  1. brew install node@10 安装10.23.0
  2. echo 'export PATH="/usr/local/opt/node@10/bin:$PATH"' >> ~/.zshrc 添加环境变量

image-20201122133234466

最后再输入gitbook -V

gitbook

总结

本篇文章结合网上的文章和自身实践,安装过程中为了提高安装速度,我换了brew的源。gitbook的安装花了我5个小时吧,故将此经验共享出来。另外,安装过程有点慢,需要耐心等待!

参考文章:

https://blog.csdn.net/qq_43528771/article/details/107949010